The CharkBoards!
Problem with my Avet Reels

This topic can be found at:
http://charkbait.evecommunity.com/eve/forums/a/tpc/f/4381010491/m/363003450101

19 October 2015, 01:09 PM
RPCROWE
Problem with my Avet Reels
When the line is a little loose on a reel, traditionally, I can just place thumb pressure on the spool and pull off the loose line - which most of the time is just a few yards at the top of the spool.
However with my Avet reels (I have a MXJ Raptor, JX 6/3 MC and a SX 5.3 MC), if I attempt to draw off the loose line on the top of the spool, more line becomes loose under my thumb. It seems like the spool itself is revolving despite the pressure on the monofilament.
I have each reel filled with Spectra with a topshot of monofilament in appropriate pound tests.
This is really a PITA and causes me a lot of problems. These are the first reels that this has happened with (but, also the first reels I have filled with Spectra and mono topshot). Should I restrict the spin of the reel using the MC control or is there some other way to prevent the spin of the spool beneath my finger pressure.
When I use a Jigmaster, I would pressure the edge of the spool itself rather than put pressure on the monofilament line to restrict the revolving of the spool.
20 October 2015, 08:32 AM
Chark
Try using your clicker.


Great Stuff!
Mark
26 October 2015, 03:36 PM
RPCROWE
I just realized the problem. I don't remember te line I had loaded as a topshot but, it was a decent brand. However, I stripped off about 50 yards of that line and it had such a memory that it was just like a spring (Or like one of those old "Slinky" toys that were popular in the 50's and 60's.

I am switching line and I suspect the problem may have been solved.

Chark - great idea about the clicker - Thanks...